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Introduction to RobotStudio

◻ What is RobotStudio?

◻ How to start it up

◻ Structured walk-through



What is RobotStudio?

◻ RobotStudio is ABB's simulation and offline 
programming software

◻ It allows robot programming to be done on a 
PC in the office without shutting down 
production

◻ It also enables robot programs to be prepared 
in advance, increasing overall productivity

◻ RobotStudio provides tools to let you perform 
tasks such as training, programming, and 
optimization without disturbing production

What is RobotStudio?

◻ RobotStudio is built on the ABB 
VirtualController, an exact copy of the real 
software that runs your robot in production

◻ It thus allows very realistic simulations to be 
performed, using real robot programs and 
configuration files identical to those used on 
the shop floor



What is RobotStudio?

How to start up RobotStudio

◻ Click here to download RobotStudio

◻ You can run in Premium Mode for 30 days; it 
then reverts to Basic Mode

◻ Follow the installation instructions for 
RobotWare and RobotStudio

◻ Once installed, double-click on the desktop 
icon to start RobotStudio

http://www.abb.com/product/ap/seitp327/a1078d9e5145d9a9c1257991004f3e69.aspx


Structured walk-through

◻ When you start up RobotStudio, by default you 
will be taken to a page where you can Create a 
new Station

◻ Click on Station with Robot Controller

◻ This will create a new, empty station

◻ You will be given a choice of robots to include 
in the station; RobotStudio will automatically 
incorporate a matching virtual controller

Structured walk-through

◻ I usually pick the IRB140T 6kg 0.81m type C 
robot, but you may choose whichever you like 
(a smaller robot is better for these exercises 
though…)

◻ If given a choice of libraries, pick 
IRB140T_6_81_C_01

◻ The robot will be inserted into an empty work 
cell



Structured walk-through

Structured walk-through

◻ Examine the different toolbars
⬜ Home

⬜ Modeling

⬜ Simulation

⬜ Controller

⬜ RAPID

⬜ Add-Ins



Structured walk-through

◻ Navigation, etc.
⬜ Ctrl + Click ‘n Drag left mouse button to pan

⬜ Ctrl + Click ‘n Drag right mouse button to zoom

⬜ Ctrl + scroll-wheel to zoom in or out (zoom is 
centered around the mouse pointer)

⬜ Ctrl + Shift + Click ‘n Drag left mouse button to 
rotate

Structured walk-through

◻ Jog the robot joints
⬜ Click on Jog Joint icon

⬜ Click on a joint, then move the joint

◻ Linearly jog the tool

⬜ Have choice of coordinate systems to use

⬜ By default, the world coordinate is used

⬜ Click on the tool mounting plate to select it

⬜ Then click on the Jog Linear icon

⬜ Click and drag the arrows to jog the tool



Structured walk-through

◻ Linearly jog the tool
⬜ Note the tool mounting plate moves linearly w.r.t. 

the world coordinate system; the robot joints 
move as needed

⬜ Click on the coordinate system dropdown box 
and select Active Tool

⬜ Notice the coordinate system on the tool 
mounting plate changes

⬜ Click and drag now on the arrows and the plate 
moves w.r.t. the local (tool) coordinate system

Structured walk-through

◻ Add a training tool to the robot
⬜ On the Home toolbar, click on the Import Library 

dropdown

⬜ Select Equipment, then scroll down to Training 
Objects and select myTool

⬜ The tool is added to the workcell, but is not 
attached to the robot yet (by default it’s located at 
(0,0,0) in the world coordinate system – in the 
middle of the robot base!)



Structured walk-through

◻ Add a training tool to the robot
⬜ In the Layout tab in the pane at the left of the 

screen, right-click on MyTool

⬜ Scroll down to “Attach to” and then click on the 
robot (there will only be one robot to select from at 
this point)

⬜ A pop-up window will appear asking if you want to 
update the position of the tool – answer Yes

⬜ The tool will now be attached to the tool mounting 
plate on the end of the robot arm

Structured walk-through

◻ Add a training tool to the robot
⬜ Note that the coordinate system for the tool is 

different from that of the tool mounting plate – 
this is perfectly acceptable

⬜ If you now go back to the Jog Linear icon, notice 
that point where the coordinate systems appear 
(world, Active Tool, etc.) is at the tip of the tool



Structured walk-through

◻ Add a work piece to the workcell
⬜ On the Home toolbar, click on the Import Library 

dropdown

⬜ Select Equipment, then scroll down to Training 
Objects and select Curve Thing

⬜ The object is added to the workcell; it ends up 
floating out in space in front of the robot (ABB is 
working on patenting anti-gravity…)

Structured walk-through

◻ Drag the Curve Thing object closer to the robot
⬜ Click on the object to select it

⬜ Click on the Move icon

⬜ Make sure the coordinate system dropdown says 
World

⬜ Click and drag on the arrows to move the object

⬜ Move the object so it is low and centered in front 
of the robot



Structured walk-through

◻ Reorient the Curve Thing object
⬜ Notice that the object is rotated some w.r.t. the 

World coordinate system; let’s get it lined up 
nicely…

⬜ Right-click on the object

⬜ Scroll down to “Set position…”and click on that

⬜ The Set Position dialog box will appear in the left-
hand pane; the reference coordinate system 
should, by default, be set to World

⬜ Notice that the object has some non-zero rotation 
in the Y and Z axes

Structured walk-through

◻ Reorient the Curve Thing object
⬜ Note that we can also see the position of the 

origin of the object w.r.t. the World coordinate 
system

⬜ Zero all of the angles and set the position to be
(550, -170, 250)

⬜ Click Apply and notice the object has been moved 
and reoriented

⬜ Close the Set Position dialog box



Structured walk-through

◻ Create a path using AutoPath
⬜ On the Home toolbar, click on the Path dropdown, 

then select AutoPath; this opens the AutoPath 
dialog box

⬜ Pick the four top edges of the lower part of the 
Curve Thing object

⬜ Note that as you click on them, path edges are 
added to the dialog box

⬜ When all four edges have been added, then click 
on the Create button

⬜ You can then close the dialog box

Structured walk-through

◻ Create a path using AutoPath
⬜ Note that a path has been created; by default it is 

called Path_10

⬜ Five ‘targets’ have also been created; they are 
called Target_10, Target_20, …, Target_50

⬜ Notice also that MoveL (move linear) instructions 
have been added to the path that reference the 
targets
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Introduction to RobotStudio

◻ Adding targets and paths using AutoPath

◻ Setting up tool orientation

◻ Moving along a path



Adding a path using AutoPath

◻ Here is the workcell after adding myTool and 
the Curve Thing

Adding a path using AutoPath

◻ Create a path using AutoPath
⬜ On the Home toolbar, click on the Path dropdown, 

then select AutoPath; this opens the AutoPath 
dialog box

⬜ Pick the four top edges of the lower part of the 
Curve Thing object

⬜ Note that as you click on them, path edges are 
added to the dialog box

⬜ When all four edges have been added, then click 
on the Create button

⬜ You can then close the dialog box



Adding a path using AutoPath

◻ You can see here the first path segment is 
being chosen

◻ Work your
way around
the surface
to create a
closed path

Adding a path using AutoPath

◻ Create a path using AutoPath
⬜ Note that a path has been created; by default it is 

called Path_10

⬜ Five ‘targets’ have also been created; they are 
called Target_10, Target_20, …, Target_50

⬜ Notice also that MoveL (move linear) instructions 
have been added to the path that reference the 
targets



Adding a path using AutoPath

Adding a path using AutoPath

◻ Right-click on Target_10 and then select View 
Tool at Target � myTool

◻ This allows you to view the EOAT at the target 
without actually moving the robot

◻ The tool may not be in the orientation you 
desire



Adding a path using AutoPath

Adding a path using AutoPath

◻ Right-click on Target_10 and then select 
Modify Target � Rotate

◻ This allows you to rotate the target in various 
ways to adjust the tool orientation (which is 
tied to the target)

◻ In this case, a 90° rotation around the Z (blue) 
axis gets the tool oriented properly



Adding a path using AutoPath

Adding a path using AutoPath



Adding a path using AutoPath

◻ If you click on the other targets, you will see 
that they too may not be oriented correctly

◻ You can copy the orientation from Target_10, 
and then apply that to the other targets

◻ Right-click on Target_10 and then select Copy 
Orientation

◻ Now select the other targets, then click on 
Apply Orientation

◻ Each of the targets will now have the same 
orienation

Adding a path using AutoPath



Adding a path using AutoPath

Adding a path using AutoPath

◻ Before we go any further, let’s make sure the 
robot can reach each of the targets with the 
selected tool orientation

◻ Right-click on Target_10 and then select View 
Robot at Target

◻ The robot and EOAT are moved according to 
the pose defined by the selected target



Adding a path using AutoPath

Adding a path using AutoPath

◻ Test the other targets

◻ Notice that not all of the targets are reachable!

◻ Specifically, Target_30 and Target_40 are not 
able to be reached

◻ You will see warning messages to this effect



Adding a path using AutoPath

Adding a path using AutoPath

◻ So let’s move the workpiece (Curve Thing) 
closer to the robot

◻ Oh, oh! We moved
the workpiece but the
targets didn’t move!



Adding a path using AutoPath

◻ The targets are tied to the World coordinate 
system

◻ At this point the only thing we can do is to 
delete the targets and path and start over 
again

◻ Shortly we’ll see a way to tie the targets to the 
workpiece so that as it moves we can move 
the  targets along with it
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Creating Workobjects

◻ Workobjects are how we are able to tie targets 
to a particular object

◻ Workobject 0 (wobj0) always exists – it is tied 
to the World coordinate system

◻ To create a new workobject, one first creates a 
user coordinate system (UCS)

Creating a User Coordinate 
System

◻ On the Home tab, click on the Frame icon

◻ Select “Frame from Three Points”

◻ This will open up a dialog box on the left side of 
the screen called Create Frame

◻ Select the “Three Point” radio button

◻ Then click in the red text box for “First Point on 
X axis (mm)”



Creating a User Coordinate 
System

Creating a User Coordinate 
System



Creating a User Coordinate 
System

◻ Select the Snap Edge tool

◻ Now move the mouse along the near edge of 
the base of the Curve Thing

◻ You will see a ball snap to the nearest edge of 
the Curve Thing and track along that edge as 
you move the mouse

Creating a User Coordinate 
System

◻ We intend to create a frame at the near left 
corner of the base of the Curve Thing, so click 
the mouse when the ball is near that corner

◻ It will replace the ball with a yellow asterisk and 
fill in the coordinates of the selected point as 
shown in the next picture



Creating a User Coordinate 
System

◻ Now select a point farther out along the same 
edge and click again

◻ The coordinates of this second point are filled 
in as the “Second point on X axis (mm)”

Creating a User Coordinate 
System

◻ Now move along the perpendicular edge to 
the left (you can see the ball in the picture 
below)

◻ Now click again; this will select a point along 
the edge and define the XY plane of the frame

◻ This fills in the
address of the third
point in “Point on Y
axis (mm)”



Creating a User Coordinate 
System

◻ Now click on Create in the dialog box to create 
the frame

◻ The origin of the frame will be where the last 
point forms the shortest perpendicular to the 
line formed by the first two
points – in this case
at the corner of the
supporting platform
of the Curve Thing

Creating a Workobject

◻ The next step is to turn the frame into a work 
object

◻ Go to the Layout tab in the
left-hand pane, then right-click
on the newly created frame,
then select “Convert Frame to
Workobject”



Creating a Workobject

◻ The frame disappears and is replaced by a 
workobject (Workobject_1 in this case) which 
you can see in the Paths&Targets tab

Creating a Workobject

◻ You will notice that the newly created 
workobject is now set as the default



Adding a path using AutoPath

◻ Now create the paths as you did in the previous 
exercise

◻ The difference in this case is that the targets are 
created with respect to the new workobject 
(Workobject_1) as opposed to the default 
workobject (wobj0)

◻ When you are done creating the path, go through 
the usual process of orienting the tool and setting 
up the target configurations

◻ Verify that the robot can move correctly along the 
path

Re-orienting the work piece

◻ Once that is done, then go back to the Home 
tab and select the Layout tab in the left-hand 
pane

◻ Click on Curve_thing in the menu then go up to 
the toolbar and use the Move and Rotate tools 
to change the position and orientation of the 
work piece

◻ Don’t get too carried away.  If you move it too 
much the robot may no longer be able to 
reach!



Re-orienting the work piece

Re-orienting the work piece

◻ Notice that the work object and the targets did 
not move along with the work piece

◻ We obviously want to be able to fix things up 
without having to recreate all of the targets, 
etc.

◻ We will use the fact that the targets were 
created relative to Workobject_1 to make this 
easy

◻ If we can correct the pose of Workobject_1 so 
it matches the newly oriented work piece, then 
all the targets will move accordingly



Correcting the pose of 
Workobject_1

◻ Go to the Paths&Targets tab in the left-hand 
pane.  Right-click on Workobject_1 – then click 
on “Modify Workobject…”

◻ The Modify Workobject
dialog box will appear

◻ In the “User Frame” section
of the dialog box, click on
“Frame by points” and then
click the down arrow to
open another dialog box

Correcting the pose of 
Workobject_1

◻ Click on the “Three-point” radio button; then 
click in the red text box under “First point on X 
axis (mm)”

◻ Now go back to the view of the robot and 
again select the Snap Edge tool (just as you 
did earlier)

◻ Then click on two points along
the same edge of the work
piece as you did before (the
X axis) and then click on a point
along the Y axis



Correcting the pose of 
Workobject_1

Correcting the pose of 
Workobject_1

◻ Go back to the dialog box and click Accept 
when you are done

◻ Then click Apply in the Modify Workobject 
dialog box



Correcting the pose of 
Workobject_1

Correcting the pose of 
Workobject_1

◻ You should now see that the work object and 
targets have moved so that they are now re-
aligned with the work piece

◻ Note that you will need to re-verify the 
configuration data for the targets

◻ The process for doing that is exactly the same 
as before



Correcting the pose of 
Workobject_1

◻ There remains one thing to do – which is to 
synchronize your code with the changes you 
have made to the station

◻ Click on the “Synchronize to VC” icon

◻ Select all of the items that appear in the pop-
up dialog box and then click on OK

◻ You can now go back to the Robot tab; note 
that the robtarget values have been updated

◻ Run the program


